Page Reports Not Loading
Incident Report for Siteimprove
Resolved
We are resolving this status in favor of a more comprehensive status here: https://status.siteimprove.com/incidents/d6vn79gfgy2n
Posted Sep 30, 2021 - 15:46 UTC
Investigating
Page reports are currently not loading.

We are working to identify the root cause and implement a solution.

Next update in 30 min.
Posted Sep 30, 2021 - 14:58 UTC
This incident affected: Platform.