Platform – Intermittent Connectivity Issues

Incident Report for Siteimprove

Resolved

The intermittent connectivity issues affecting our platform have now been resolved. Our team has verified that the platform is functioning as expected.

If you continue to experience any issues, please reach out to our support team.

Thank you for your patience, and we appreciate your understanding!
Posted Mar 15, 2025 - 03:20 UTC

Identified

We are currently experiencing intermittent connectivity issues preventing our platform from loading consistently. This is due to an external service being unavailable, which impacts certain dependencies used within our platform.

You may experience general platform slowness, missing UI elements, or temporary login issues.

Our team is actively monitoring the situation and exploring mitigation strategies. We do not foresee this being reconciled over the weekend. Therefore, we will provide an update Monday, March 17th at the latest.

We apologize for the inconvenience and appreciate your patience.
Posted Mar 14, 2025 - 20:48 UTC
This incident affected: Platform.