New sites not working
Incident Report for Siteimprove
Resolved
We have now fixed the issue, and the new sites created that were not working correctly should now be working. We apologize for the inconvenience.
Posted Jun 23, 2020 - 09:04 UTC
Identified
We're currently experiencing issues with new sites not working correctly. This means that if you create a new site in the platform, even though the site seems to be created correctly, it will not work correctly. We're working on fixing the issue.

Please be aware that this only affects sites that have been created since June 22nd, all other sites are working fine.
Posted Jun 22, 2020 - 13:24 UTC
This incident affected: Platform.