We are resolving this issue. While systems are operating normally, if you continue to experience any issues, please submit a support ticket through our Help Center located at the bottom right-hand-side of the Siteimprove platform and our team will assist you.
Posted Sep 17, 2025 - 19:44 UTC
Monitoring
Thank you for your patience, and we apologize for the delay in providing an update. We have applied a fix to the Analytics data ingestion issue, and customers should now see Analytics features functioning as expected. Please note: No data has been lost.
Some additional work is still required to ensure full recovery. Our team will complete this tomorrow, and we will continue to monitor closely until the system is fully restored.
Posted Sep 17, 2025 - 18:23 UTC
Update
Thank you for your continued patience. Our Dev. Team is still working on a fix. There is still some delay in data ingestion, and our team will continue to monitor closely.
We will provide the next update within 1 hour.
Posted Sep 17, 2025 - 15:16 UTC
Identified
The Dev. Team has found the issue and they're working on a fix. Thanks for your patience!
We’ll have an update at the top of the hour.
Posted Sep 17, 2025 - 14:08 UTC
Investigating
We are currently investigating an issue with Analytics data ingestion. Customers may experience delayed or unavailable data in Live Analytics, Behavior Maps, and other Analytics-related modules.
No data has been lost. Data collected in the last 1–2 hours may be delayed in appearing. Our Development Team is actively working to resolve the issue.
We will provide the next update within 1 hour.
Posted Sep 17, 2025 - 13:12 UTC
This incident affected: Products (Analytics / Usability).