Siteimprove Platform Login Errors

Incident Report for Siteimprove

Resolved

The issue that prevented certain Siteimprove customers from logging in has been resolved.

If you have any additional questions or feedback, please submit a new support ticket through our Help Center ("?" button) located at the top right-hand-side of the Siteimprove platform.
Posted Feb 27, 2026 - 15:37 UTC

Monitoring

A fix has been implemented.

Customers should now be able to login successfully.
Posted Feb 27, 2026 - 15:09 UTC

Identified

We’ve found the issue and we’re working on a fix. Thanks for your patience!
Posted Feb 27, 2026 - 14:59 UTC

Investigating

We are currently experiencing issues where some customers are unable to log in to the Siteimprove platform through siteimprove.com and my2.siteimprove.com.

Impact:

- Users who are already logged in should not experience disruption unless they log out or their session times out.
- New login attempts may fail.
- Users are seeing the following error message: Authentication failed: SubscriptionAccess could not be built. TraceId: xxxx

Our Development Team is actively working to identify the root cause and resolve the issue as quickly as possible.

We apologize for this inconvenience. We'll continue to keep you updated.
Posted Feb 27, 2026 - 14:49 UTC
This incident affected: Platform.