Emergency Maintenance
Incident Report for Siteimprove
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 12:27 UTC
Investigating
We are undergoing maintenance with short notice. The system will be unavailable for a subset of customers.
Posted Nov 15, 2022 - 11:57 UTC
This incident affected: Platform and API / Integrations.