SEO Enterprise - Activity Plan Overview unavailable for some users

Incident Report for Siteimprove

Resolved

Nice! The issue affecting SEO Enterprise - Activity Plan Overview is all sorted.

We’re sorry for holding you up! If you have any additional questions or feedback, please submit a new support ticket through our Help Center located at the bottom right-hand side of the Siteimprove platform.
Posted Mar 10, 2025 - 15:49 UTC

Identified

Good news! We’ve found the issue, and we’re working on a fix. Thanks for your patience!


We’ll have an update at the top of the hour. Stay tuned!
Posted Mar 10, 2025 - 14:37 UTC

Investigating

Uh oh! We seem to be having a problem with the SEO module. Our team is making every effort to get things up and running again.

You may be experiencing the SEO Enterprise - Activity Plan Overview to be unavailable.

We’ll have an update at the top of the hour. Stay tuned!
Posted Mar 10, 2025 - 14:30 UTC
This incident affected: Products (SEO).