Siteimprove Help Center, Chat, and Support Issue
Incident Report for Siteimprove
Resolved
We have seen no further disruption of Support services during the last 30 minutes.
Posted Jul 17, 2020 - 22:19 UTC
Monitoring
Help Center, Chat, and Support systems appearing to be working again. We will continue to monitor the situation for the next 30 minutes to ensure there are no further disruptions.
Posted Jul 17, 2020 - 21:39 UTC
Identified
We have identified an issue impacting Siteimprove's Help Center, Chat, and Support systems for North American customers. The Help Center and Chat functions are not available for users and incoming responses to Support tickets are not being processed consistently. We are working with our vendor to resolve the issue as quickly as possible.

We will post another update in approximately 30 minutes as new information becomes available.
Posted Jul 17, 2020 - 21:34 UTC