Platform – Outage
Incident Report for Siteimprove
Resolved
Nice! The issue affecting the Platform is all sorted.

We’re sorry for holding you up! If you have any additional questions or feedback, please submit a new support ticket through our Help Center located at the bottom right-hand-side of the Siteimprove platform.
Posted Jun 10, 2024 - 14:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2024 - 13:37 UTC
Investigating
Uh oh! We seem to be having a problem.

Our team is making every effort to get things up and running again.

You may be experiencing issues with getting the platform to load and/or log into the platform.

We’ll have an update at the top of the hour. Stay tuned!
Posted Jun 10, 2024 - 13:20 UTC
This incident affected: Platform.