Platform login not working
Incident Report for Siteimprove
Resolved
We have now fixed the issue and the platform is available again. We apologize for the inconvenience.
Posted Apr 16, 2020 - 13:05 UTC
Investigating
Users are currently unable to log into the platform. We're looking into this with highest priority.
Posted Apr 16, 2020 - 12:58 UTC
This incident affected: API / Integrations.