"Payment Overdue" Message Issue
Incident Report for Siteimprove
Resolved
The issue has been corrected. Users should no longer receive the notification when logging into the platform.
Posted Dec 14, 2020 - 15:17 UTC
Investigating
We are currently experiencing a minor issue causing users to receive an in-platform notification that a payment is overdue. We are working to correct the issue and remove the reminder as quickly as possible. Users who are presented with the message can bypass it and continue using the platform normally.

We will update the status page once the situation has been corrected.
Posted Dec 14, 2020 - 15:11 UTC
This incident affected: Platform.