Platform is currently unavailable
Incident Report for Siteimprove
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 14:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2020 - 11:44 UTC
Investigating
We are currently investigating this issue.
Posted Apr 08, 2020 - 11:09 UTC
This incident affected: Platform and API.