SEO: Activity plans with competitors
Incident Report for Siteimprove
Resolved
This incident has now been resolved. We will continue to monitor SEO activity plan functionality.
Posted 4 months ago. Mar 28, 2019 - 10:51 UTC
Identified
An issue has been identified while creating or editing activity plans containing competitors. We expect the issue to be solved in the next 24 hours. We apologize for the inconvenience.
Posted 4 months ago. Mar 27, 2019 - 15:05 UTC
This incident affected: Platform.