Degraded Performance - Crawler/Linkchecker

Incident Report for Siteimprove

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2026 - 13:45 UTC

Investigating

We are currently investigating an issue causing delays in Siteimprove’s crawler and linkchecker processing. Sites are successfully entering the queue for scanning; however, some scans are not completing as expected.

This issue appears to be affecting a limited number of customers. Our development team is aware of the behavior and is actively working to restore normal processing.

We will provide updates here as more information becomes available.
Posted Feb 24, 2026 - 03:58 UTC
This incident affects: Products (Crawler).