Platform Unavailable
Incident Report for Siteimprove
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 11:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2021 - 09:18 UTC
Investigating
The platform is currently experiencing a disruption and users are receiving error messages when attempting to load the interface. We are looking into the issue as a high priority and will update on progress as soon as more information is available.
Posted Feb 18, 2021 - 08:12 UTC
This incident affected: Platform.