Emergency Maintenance

Incident Report for Siteimprove

Resolved

Thank you for your patience and understanding while we underwent maintenance.

We’re sorry for holding you up! If you have any additional questions or feedback, please submit a new support ticket through our Help Center located at the bottom right-hand side of the Siteimprove platform.
Posted Oct 20, 2022 - 20:24 UTC

Investigating

We are undergoing maintenance with short notice. The system will be unavailable for a subset of customers.
Posted Oct 20, 2022 - 19:54 UTC
This incident affected: Platform and API / Integrations.