Quality Assurance Page Reports and My Sites
Incident Report for Siteimprove
Resolved
This incident has now been resolved. We will continue to monitor QA Page Reports and My Sites functionality.
Posted 6 days ago. Mar 15, 2019 - 16:11 UTC
Investigating
Some customers are encountering errors when accessing QA Page Reports and the My Sites list. We are currently investigating.
Posted 6 days ago. Mar 15, 2019 - 15:40 UTC
This incident affected: Platform.