Unscheduled Maintenance
Incident Report for Siteimprove
Resolved
The maintenance has been completed and our services are now fully available.
Posted Sep 29, 2021 - 11:27 UTC
Identified
Siteimprove is performing an unscheduled maintenance on our platform. Some users may not be able to access our services for the next 60 minutes. We apologize for any inconvenience this may cause.
Posted Sep 29, 2021 - 10:41 UTC
This incident affected: Platform.