Platform – Outage
Incident Report for Siteimprove
Resolved
Nice! The issue affecting the Platform access is all sorted.

We’re sorry for holding you up! If you have any additional questions or feedback, please submit a new support ticket through our Help Center located at the bottom right-hand-side of the Siteimprove platform.
Posted Dec 01, 2022 - 10:00 UTC
Monitoring
Don’t fret! A fix has been implemented and we’re checking in to make sure that the access issue is solved.

You should now be able to access the Siteimprove Platform.

We’ll have an update at the top of the hour. Stay tuned!
Posted Dec 01, 2022 - 09:32 UTC
Investigating
Uh oh! We seem to be having a problem.

Our team is making every effort to get things up and running again.

You may be experiencing issues accessing the Siteimprove Platform.

We’ll have an update at the top of the hour. Stay tuned!
Posted Dec 01, 2022 - 09:26 UTC
This incident affected: Platform.