Slight Delays in Crawl Start Times

Incident Report for Siteimprove

Resolved

Nice! The issue affecting crawl start times is all sorted.

We’re sorry for holding you up! If you have any additional questions or feedback, please submit a new support ticket through our Help Center located at the bottom right-hand-side of the Siteimprove platform.
Posted Apr 17, 2025 - 14:46 UTC

Monitoring

We’ve identified and addressed an issue causing slight delays in crawl start times. You may notice minor delays over the next few days as the system catches up. We’ll continue to monitor and work to return everything to normal speed as quickly as possible.
Posted Apr 14, 2025 - 15:09 UTC
This incident affected: Products (Crawler).