Platform is currently periodically unavailable
Incident Report for Siteimprove
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 14:06 UTC
Investigating
We are currently investigating this issue.
Posted Jul 28, 2020 - 13:53 UTC
This incident affected: Platform and API.