Platform Unavailable
Incident Report for Siteimprove
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 08:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2020 - 07:17 UTC
Investigating
We are experiencing issues accessing the platform. We're currently investigating the cause.
Posted Apr 23, 2020 - 06:52 UTC
This incident affected: Platform and API.