Platform unavailable
Incident Report for Siteimprove
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 07:41 UTC
Update
We are continuing to investigate this issue.
Posted Jul 23, 2020 - 07:34 UTC
Investigating
Our platform is currently unresponsive - we are investigating.
Posted Jul 23, 2020 - 07:34 UTC
This incident affected: Platform and API.