On-demand reports
Incident Report for Siteimprove
Resolved
The ability to run on-demand reports has been restored.
Posted about 2 months ago. Jun 26, 2019 - 16:54 UTC
Identified
The ability to run on-demand reports is currently unavailable. We are working to resolve this as soon as possible.
Posted about 2 months ago. Jun 26, 2019 - 16:05 UTC
This incident affected: Platform.