Platform failing to load
Incident Report for Siteimprove
Resolved
Nice! The issue that affected the platform from loading successfully is all sorted.

We’re sorry for holding you up! If you have any additional questions or feedback, please submit a new support ticket through our Help Center located at the bottom right-hand side of the Siteimprove platform.
Posted Jul 06, 2022 - 20:02 UTC
Monitoring
Don’t fret! A fix is on the way and we’re checking in to make sure the Siteimprove platform loads successfully.

We’ll have an update at the top of the hour. Stay tuned!
Posted Jul 06, 2022 - 19:24 UTC
Investigating
Uh oh! We seem to be having a problem.

Our team is making every effort to get things up and running again.

You may be experiencing a long loading screen when trying to navigate to https://my2.siteimprove.com/ (the Siteimprove platform).

We’ll have an update at the top of the hour. Stay tuned!
Posted Jul 06, 2022 - 19:16 UTC
This incident affected: Platform.