Delayed processing of Analytics data
Incident Report for Siteimprove
Resolved
This incident has been resolved.
Posted 15 days ago. Aug 05, 2019 - 20:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 16 days ago. Aug 04, 2019 - 20:02 UTC
This incident affected: Platform.