Monitoring
Incident Report for Siteimprove
Resolved
Nice! The issue affecting the platform is all sorted.

We’re sorry for holding you up! If you have any additional questions or feedback, please submit a new support ticket through our Help Center located at the bottom right-hand-side of the Siteimprove platform.
Posted Jun 17, 2024 - 15:09 UTC
Monitoring
A small group of users were experiencing an error when trying to log into the platform.
Don’t fret! A fix is on the way and we’re checking in to make sure the platform can be accessed by all users. We'll continue to monitor to ensure there are no further disruptions.

We’ll have an update at the top of the hour. Stay tuned!
Posted Jun 17, 2024 - 13:02 UTC
This incident affected: Platform.