Analytics - Partial outage
Incident Report for Siteimprove
Resolved
The issue affecting the Analytics / Usability product is resolved.
We apologize for any inconvenience this may have caused. If you have any additional questions, comments, or concerns, please submit a new support ticket through our Help Center. You can access the Help Center via our "?" button located at the bottom right-hand-side of the Siteimprove platform.
Posted May 30, 2022 - 05:11 UTC
Investigating
We’re currently experiencing a service disruption with the Analytics / Usability modules. Our Software Development Team is working to identify the root cause and implement a solution.
Users may be experiencing a partial outage for a subset of the analytics service.

Next update in 30 minutes.
Posted May 30, 2022 - 04:38 UTC
This incident affected: Products (Analytics / Usability).